1. Snoman

    Snoman Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jul 16, 2011
    Location:
    northern wi
    Local Time:
    5:37 AM
    Hey i just put a rebuild kit in my b body 833 trans and it all went well, i installed new syncro rings, bearings, sliders, keys, now I have one question, it seem to up shift ok, but when i down shift into second i get a little grind when it goes into 2nd gear. It only does it when i pull pretty hard on the shifter, if i don't pull hard it wont go in at all until slower speeds. What do you guys think? Thanks
     
  2. dano

    dano Evil Handy Man FABO Gold Member

    Messages:
    2,345
    Likes Received:
    379
    Joined:
    Aug 22, 2005
    Location:
    Gresham, Oregon
    Local Time:
    3:37 AM
    Is your shifter mechanism new too?
     
  3. Snoman

    Snoman Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jul 16, 2011
    Location:
    northern wi
    Local Time:
    5:37 AM
    no it is the old shifter mech. seem to be in pretty good shape, I forgot to add i am using synthetic atf trans oil too.
     
  4. oldkimmer

    oldkimmer FABO Gold Member FABO Gold Member

    Messages:
    10,473
    Likes Received:
    1303
    Joined:
    Nov 11, 2006
    Location:
    Kindersley, Saskatchewan,
    Local Time:
    5:37 AM
    ............THERES UR PROBLEM....DO NOT USE SYNTHETIC anything in an 833.......kim.......
     
  5. Snoman

    Snoman Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jul 16, 2011
    Location:
    northern wi
    Local Time:
    5:37 AM
    ok i will swap out the fluid and give it a try
     
  6. chignikred

    chignikred Well-Known Member

    Messages:
    402
    Likes Received:
    16
    Joined:
    Apr 12, 2009
    Location:
    WA
    Local Time:
    3:37 AM
    this usually is a stop ring issue. you did put in new?
     
  7. omahamoparguy

    omahamoparguy Well-Known Member

    Messages:
    762
    Likes Received:
    20
    Joined:
    Feb 19, 2010
    Local Time:
    4:37 AM
    yes, depending of what type of stop rings and synchros you have that tells you what type of fluid to use. Old style, you use old 75/90 gear oil. this makes the synchro's slow down fast like when you are downshifting.
     
  8. Snoman

    Snoman Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jul 16, 2011
    Location:
    northern wi
    Local Time:
    5:37 AM
    I put in a rebuild kit from brewers, I guess i am not sure what you mean by stop rings?, I put in new sliders, new sycros, new keys, bearing. I didn't get a chance to change the fluid yet. hopefully soon what fluid should i use. Thanks for the help
     
  9. mjs69gts

    mjs69gts Well-Known Member

    Messages:
    847
    Likes Received:
    14
    Joined:
    Jan 7, 2011
    Location:
    madison wi
    Local Time:
    5:37 AM
    use 75w90 gear lube
     
  10. Snoman

    Snoman Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jul 16, 2011
    Location:
    northern wi
    Local Time:
    5:37 AM
    any specific kind of 75 90, I thought someone said to us a CL 4 rated gear lube. which one would that be. thanks
     
  1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.