Fresh 904 skips 2nd gear

Scott Warner

Well-Known Member
Joined
Aug 18, 2019
Messages
133
Reaction score
82
Location
North West Phoenix
First Tqflite 904 rebuild in 30 years.
I got a good kit with alto frictions and kyolene steels. All new seals, all measurements fell within spec.

There was already a proven TF-2 kit in the valvebody which remained intact.

I added a CRT multi spring to the front as the big anti wound coil was weak. Also added new rear and middle aluminum servos. Front band apply servo was left alone.

First drive attempt first gear wound up to about 3k...and straight to 3rd. Only went a couple miles....different throttle positions were tried...no change.

I turned around and got about a block from the house (fully warmed up now) and got 1-2, and 2-3 shifts pulling away from the light. I went another block and it wouldnt do it again.

I readjusted the front band...same result.

Next attempt I only backed off 1 turn from 78 inlbs. Nope.

Left it at 78 inlbs...seems better..but will wear front band quickly.

Thinking I should take a few springs out of the CRT unit.

Thoughts?

And many thanks.
 
Last edited:

TrailBeast

AKA Mopars4us on Youtube
Joined
Mar 11, 2011
Messages
21,742
Reaction score
10,360
Location
Arizona
First Tqflite 904 rebuild in 30 years.
I got a good kit with alto frictions and kyolene steels. All new seals, all measurements fell within spec.

There was already a proven TF-2 kit in the valvebody which remained intact.

I added a CRT multi spring to the front as the big anti wound coil was weak. Also added new rear and middle aluminum servos. Front band apply servo was left alone.

First drive attempt first gear wound up to about 3k...and straight to 3rd. Only went a couple miles....different throttle positions were tried...no change.

I turned around and got about a block from the house (fully warmed up now) and got 1-2, and 2-3 shifts pulling away from the light. I went another block and it wouldnt do it again.

I readjusted the front band...same result.

Next attempt I only backed off 1 turn from 78 inlbs. Nope.

Left it at 78 inlbs...seems better..but will wear front band quickly.

Thinking I should take a few springs out of the CRT unit.

Thoughts?

And many thanks.
It does sound like a valve hanging up to me as well.
When I was doing transmissions for a national chain we used this stuff when we had sticky valves in the valve body, or sticking governor valves.
It really does work for that.
Might be worth a try, and keep you from having to tear into it again.

4A7E98CE-5279-4093-8B91-353432A0D3C9.jpeg
 

Scott Warner

Well-Known Member
Joined
Aug 18, 2019
Messages
133
Reaction score
82
Location
North West Phoenix
Well...it isnt a valve..but close!

I think I found the issue.

The second gear servo pin was stuck in the out position...and appears slightly bent.

Guess I need a servo. The 727 servo is the same one right? I have a 727 core to pull from...or I could spend more money on a
Sonnax 7722830.
 

Scott Warner

Well-Known Member
Joined
Aug 18, 2019
Messages
133
Reaction score
82
Location
North West Phoenix
Little more research on my part shows that sonnax number is for a 727.
Does anyone know if they make one for a 904? Or have a spare 904 servo? For a 1969 (small diameter servo)?
 
Last edited:
Top