Here's one for ya...

Electrical and Ignition

  1. dart_68

    dart_68 Well-Known Member

    Messages:
    779
    Likes Received:
    580
    Joined:
    May 25, 2017
    Location:
    Lakewood, CO
    Local Time:
    6:57 AM
    Was checking my ignition to see what my initial and total advance was for mechanical advance alone and with with vacuum. (360 LA)

    Idling @ 800 my initial was 16* with vacuum disconnected. When I slowly began to raise the RPM the timing went down, yes down, to 10*. Then as the RPM continued up it got to a total of 20* at about 3500. I thought I was seeing things so I kept checking it and it did the same thing every time. At least that was consistent.

    When I added the vacuum the total was over 40* at about 4000 but the RPM had a big problem with going higher as the ignition would breakup. Could hear it, see it with the timing light, and shook the whole car pretty bad.

    Not sure what's going on but I've been fighting gremlins on this thing for a while now and have thrown in the towel on this ignition system. The gentleman I bought it from said he had problems too and eventually gave up. I thought I could find the problem(s) with enough time but enough is enough...I'm done. System is a stock Mopar electronic distributor triggering an 8 pin HEI module and coil. I decided on a Petronix III distributor as the module is internal and has a built in rev limiter. Had to get a coil too to match the module.

    Not really asking any question here but if you have any input on what was going on I'd love to hear it.

    Thanks!
     
  2. mvh

    mvh FABO Gold Member FABO Gold Member

    Messages:
    1,767
    Likes Received:
    470
    Joined:
    Dec 17, 2007
    Location:
    Menlo Park, CA
    Local Time:
    5:57 AM
    Well, you would seem to have too much initial timing. 10º at 800rpm might have been a better starting point. That would put you at 34º at 4000rpm which would be reasonable as a max advance. I would have just retarded the initial timing to 10º and see how that worked.
     
  3. TT5.9mag

    TT5.9mag Two atmospheres are better than one

    Messages:
    2,146
    Likes Received:
    2148
    Joined:
    May 5, 2016
    Location:
    So cal
    Local Time:
    5:57 AM
    Some of those HEI modules had retard functions in them when grounding a certain pin. Some pins could also be used for a start retard if I remember correctly. Sounds like you made a good decision to nix the whole setup and start fresh.
     
  4. TT5.9mag

    TT5.9mag Two atmospheres are better than one

    Messages:
    2,146
    Likes Received:
    2148
    Joined:
    May 5, 2016
    Location:
    So cal
    Local Time:
    5:57 AM
    40 degrees at 4000 with the vacuum can hooked up to ported and no load is not “too much”. It sounds like a good recipe for fuel mileage to me.
     
  5. burdar

    burdar Owen's Dad

    Messages:
    1,280
    Likes Received:
    353
    Joined:
    Aug 15, 2013
    Location:
    Iowa
    Local Time:
    7:57 AM
    The Pertronix distributors are really tall. You'll need to run angled plug wire boots on the cap otherwise you'll hit the wiper motor body. Even then, the boot will be very close to the wiper motor. You might need to index the oil pump drive gear over 1 tooth to position the distributor cap in the best location.
     
    • Thanks! Thanks! x 1
    • dano

      dano Evil Handy Man

      Messages:
      4,149
      Likes Received:
      1997
      Joined:
      Aug 22, 2005
      Location:
      Gresham, Oregon
      Local Time:
      5:57 AM
      Why not use a Mopar box with the distributor you have?

      Pertronix has a GM HEI Module with a rev limiter too.
       
    • Syleng1

      Syleng1 Karma is real and Life is short... FABO Gold Member

      Messages:
      2,412
      Likes Received:
      2099
      Joined:
      Jul 5, 2005
      Location:
      North Franklin, CT
      Local Time:
      8:57 AM
      With the Timing going down when you bring up rpm- are you connected to the proper port on the carb?
       
    • 67Dart273

      67Dart273 FABO Gold Member FABO Gold Member

      Messages:
      52,500
      Likes Received:
      21653
      Joined:
      Oct 14, 2010
      Location:
      Idaho
      Local Time:
      5:57 AM
      ^^THIS^^ is where I'd start. Check timing at idle, remove hose, see if timing changes
       
    • RustyRatRod

      RustyRatRod I was born on a Monday. Not last Monday. FABO Gold Member

      Messages:
      81,583
      Likes Received:
      61241
      Joined:
      Jun 7, 2010
      Location:
      Georgia
      Local Time:
      8:57 AM
      I had a friend who had a 383 distributor in a 318 once. Because it is made to turn the opposite direct, it was retarding timing with more RPM. It's a close enough fit to bolt in and run.....and not run well like you describe.
       
      • Like Like x 1
      • Thanks! Thanks! x 1
      • Bewy

        Bewy Well-Known Member

        Messages:
        1,535
        Likes Received:
        983
        Joined:
        Jan 1, 2021
        Location:
        Australia
        Local Time:
        12:57 AM
        Use the 4 pin module & your problems will go away....
        Pertronix modules have a checkered reputation. Cannot go wrong with the stock GM 4 pin module for your combo; coil should work ok with it if it is an E-core.
        If you want a little more 'oomph' from the ign system, use the MSD 83647 module; has built in rev limiter, switches 7.5 amps v stock 5.5 amps.
         
        • Thanks! Thanks! x 1
        • dart_68

          dart_68 Well-Known Member

          Messages:
          779
          Likes Received:
          580
          Joined:
          May 25, 2017
          Location:
          Lakewood, CO
          Local Time:
          6:57 AM
          Because I believe the dist is part of the problem.
           
          • Thanks! Thanks! x 1
          • dart_68

            dart_68 Well-Known Member

            Messages:
            779
            Likes Received:
            580
            Joined:
            May 25, 2017
            Location:
            Lakewood, CO
            Local Time:
            6:57 AM
            Vacuum was disconnected at that time. I was trying to see what my mechanical advance was.
             
          • dart_68

            dart_68 Well-Known Member

            Messages:
            779
            Likes Received:
            580
            Joined:
            May 25, 2017
            Location:
            Lakewood, CO
            Local Time:
            6:57 AM
            Vacuum was disconnected.
             
          1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
            By continuing to use this site, you are consenting to our use of cookies.