no parking lights or tail lights

Electrical and Ignition

  1. whiteduster

    whiteduster Well-Known Member

    Messages:
    365
    Likes Received:
    10
    Joined:
    Aug 5, 2008
    Local Time:
    3:27 AM
    i got a 74 duster my parking lights and tail lights stop working any ideas
     
  2. Dartswinger70

    Dartswinger70 Only thing I ever bought new was a Fender Strat

    Messages:
    3,626
    Likes Received:
    2018
    Joined:
    Sep 20, 2005
    Location:
    Southeastern Pa.
    Local Time:
    4:27 AM
    Fuse? I'd check that first.
     
  3. Early a body

    Early a body Well-Known Member

    Messages:
    197
    Likes Received:
    90
    Joined:
    Jun 25, 2018
    Location:
    Nevada
    Local Time:
    1:27 AM
    most likely the fuse if it happened all of a sudden. What were doing when it stopped working. Doing any other work at the time?
     
  4. whiteduster

    whiteduster Well-Known Member

    Messages:
    365
    Likes Received:
    10
    Joined:
    Aug 5, 2008
    Local Time:
    3:27 AM
    all the fuses look fine the only ground i see is the wire you have to bolt in i sanded it down still nothing the drivers side parking light was not blinking it started to smoke then it was fine for a few days but stopped blinking so i decided to splice in another parking light thats when the parking lights and head lights stopped for good
     
  5. Dartswinger70

    Dartswinger70 Only thing I ever bought new was a Fender Strat

    Messages:
    3,626
    Likes Received:
    2018
    Joined:
    Sep 20, 2005
    Location:
    Southeastern Pa.
    Local Time:
    4:27 AM
    Uh oh..you didn't say anything about splice...test each side of fuse with test light. Looks can be deceiving, fuse can be fried behind the end where ya cant see..although it should be black, either way maybe there isn't power to one side of fuse so test light would tell you...
     
  6. Early a body

    Early a body Well-Known Member

    Messages:
    197
    Likes Received:
    90
    Joined:
    Jun 25, 2018
    Location:
    Nevada
    Local Time:
    1:27 AM

    Not sure where you are located but it could be that you need a new headlamp switch/ you have a corrosion problem. Could also be the turn signal switch in the steering column has gone bad/ burned out. But i would remove the splice din park light and then see if it comes back. Clean all the connectors with electrical cleaner, they sell it at home depot. ace hardware etc. and see what happens.
     
  7. whiteduster

    whiteduster Well-Known Member

    Messages:
    365
    Likes Received:
    10
    Joined:
    Aug 5, 2008
    Local Time:
    3:27 AM
    the brake lights came back on i looked at the fuse when i took it out the top of the fuse came off still no parcking lights i'll trl to cut the splice i made and try my test light on the fuse i'll even order a new turn single switch for the hell of it
     
  8. whiteduster

    whiteduster Well-Known Member

    Messages:
    365
    Likes Received:
    10
    Joined:
    Aug 5, 2008
    Local Time:
    3:27 AM
    i got the running lights working it was not getting power at the bulk head so i replaced the male and female connector thanks for the tips now i have to see if the drivers side running light will blink
     
  1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.