Performance Indicator Gauge

Electrical and Ignition

  1. bobscuda67

    bobscuda67 Well-Known Member

    Messages:
    1,905
    Likes Received:
    166
    Joined:
    Aug 27, 2005
    Location:
    Michigan
    Local Time:
    2:03 PM
    I have my dash out trying to get the gauges to function. My performance gauge used to work fine two years ago and last year it started to work very slowly.
    This year it worked even slower, so now that the dash is out I'm trying to fix it.
    I removed the nipple and there was some corrosion inside the nut. What has got me totally confused is what was under the vacuum fitting. There's a staked screw under it with no hole in anywhere in sight.
    Ok, IMG_1290.JPG I give, how the hell is this supposed to pull a vacuum through it?
     
    • Agree Agree x 1
    • toolmanmike

      toolmanmike FABO MODERATOR Staff Member FABO Gold Member

      Messages:
      49,400
      Likes Received:
      34179
      Joined:
      Jan 18, 2006
      Location:
      Iowa
      Local Time:
      1:03 PM
      OOPS. It looks broke!
       
    • A56

      A56 MoParAffliction FABO Gold Member

      Messages:
      1,011
      Likes Received:
      878
      Joined:
      Jun 24, 2014
      Location:
      White Oak, N.C.
      Local Time:
      12:03 PM
      Here's a picture of one from a Dodge console mounted vacuum gauge the nipple removed
      probably more questions than answers.

      s-l500 (1).jpg
       
      Last edited: Jun 2, 2020
    • Mattax

      Mattax Just the facts, ma'am FABO Gold Member

      Messages:
      10,532
      Likes Received:
      6572
      Joined:
      Feb 7, 2013
      Location:
      Phila. Pa
      Local Time:
      2:03 PM
      Needs a 1/8" hose barb fitting like this. or did you just take that off during disassembly?
      upload_2020-6-2_19-5-7.png

      I beleive inside is a bourdon tube.
       
      • Agree Agree x 2
      • Thanks! Thanks! x 1
      • qkcuda

        qkcuda Well-Known Member

        Messages:
        1,218
        Likes Received:
        911
        Joined:
        Mar 6, 2013
        Location:
        Jarvis, Ontario
        Local Time:
        2:03 PM
        Years ago I took a drill and opened up the hole. Can't remember how much, but it worked
         
      • bobscuda67

        bobscuda67 Well-Known Member

        Messages:
        1,905
        Likes Received:
        166
        Joined:
        Aug 27, 2005
        Location:
        Michigan
        Local Time:
        2:03 PM
        Yes the hose barb is in the picture at the top. I put a few drops of penetrating oil in it and it loosened up.
        It moves left to right now.
        I think you're right that it some kind of tube because it's not a screw.
         
        • Like Like x 1
        • halifaxhops

          halifaxhops It's going to get stupid around here! FABO Gold Member

          Messages:
          59,173
          Likes Received:
          27441
          Joined:
          Jan 20, 2014
          Location:
          CENTRURAL, PA
          Local Time:
          2:03 PM
          I believe that is a adjustment for it, and has a hole drilled into it. . It is basically a vacuum gauge.
           
          • Agree Agree x 1
          • Mattax

            Mattax Just the facts, ma'am FABO Gold Member

            Messages:
            10,532
            Likes Received:
            6572
            Joined:
            Feb 7, 2013
            Location:
            Phila. Pa
            Local Time:
            2:03 PM
            Test it for leaking with a mityvac or other vacuum pump.
             
          • bobscuda67

            bobscuda67 Well-Known Member

            Messages:
            1,905
            Likes Received:
            166
            Joined:
            Aug 27, 2005
            Location:
            Michigan
            Local Time:
            2:03 PM
            Well I used my HVAC vacuum pump on it yesterday and the needle didn't move. The pump pulls 29" so it should have done something. When the vacuum was on it the coiled arm did move slightly but not enough to get the needle off of the needle rest stud.
            I put it back in the dash and gave up on it. It lasted 53 years so I cant complain. I guess it'll be something else to look for at swap meets.
             
          • Mattax

            Mattax Just the facts, ma'am FABO Gold Member

            Messages:
            10,532
            Likes Received:
            6572
            Joined:
            Feb 7, 2013
            Location:
            Phila. Pa
            Local Time:
            2:03 PM
            I thought I saw one for sale here recently.
             
          • RedFish

            RedFish Well-Known Member

            Messages:
            24,164
            Likes Received:
            2779
            Joined:
            Sep 5, 2007
            Local Time:
            1:03 PM
            I had just stated in a recent thread that I have never seen a failed performance indicator. As of this morning that is no longer true. How contamination got there is a interesting question. Vaporizing fuel deteriorating the rubber tube at engine off maybe? Small crack/hole in the brass actuator coil? Who knows?
             
          • famous bob

            famous bob mopar misfit FABO Gold Member

            Messages:
            16,580
            Likes Received:
            6362
            Joined:
            Aug 14, 2011
            Location:
            okla
            Local Time:
            1:03 PM
            MINE DOESN`T WORK EITHER, HAVE BEEN LOOKING FOR SOMETHING TO COVER IT UP WITH , THAT DOESN`T INVOVLVE REMOVING THE DASH AGAIN . hope to be done w/ that .
             
          • A56

            A56 MoParAffliction FABO Gold Member

            Messages:
            1,011
            Likes Received:
            878
            Joined:
            Jun 24, 2014
            Location:
            White Oak, N.C.
            Local Time:
            12:03 PM
            I'd put a clock in there. Even if that breaks it'll be correct twice a day!:rolleyes:
             
          • bobscuda67

            bobscuda67 Well-Known Member

            Messages:
            1,905
            Likes Received:
            166
            Joined:
            Aug 27, 2005
            Location:
            Michigan
            Local Time:
            2:03 PM
            I got it all back together now. It still doesn't work.
             
          • Mattax

            Mattax Just the facts, ma'am FABO Gold Member

            Messages:
            10,532
            Likes Received:
            6572
            Joined:
            Feb 7, 2013
            Location:
            Phila. Pa
            Local Time:
            2:03 PM
            If its holding vacuum, but the tube is not moving the link (I assume you opened it) then it would seem like blockage.

            Bob's is not cheap but its in Mich. Wolfe is another possible place for getting it fixed.
             
          • bobscuda67

            bobscuda67 Well-Known Member

            Messages:
            1,905
            Likes Received:
            166
            Joined:
            Aug 27, 2005
            Location:
            Michigan
            Local Time:
            2:03 PM
            Yes, its holding a vacuum and I put all back together and got the dash installed in the car. I didn't want it to sit while I look for parts.
            I'm sure it is some corrosion in it because there was some under the nipple. It's my fault because I left the hose off of the intake three years ago when I changed the cam out.
            I think I'll find another one and have that one redone so I can swap them out quick or wait for the winter to repair mine.
             
          1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
            By continuing to use this site, you are consenting to our use of cookies.