Rebuilt Street Averager starting problem

Discussion in 'Fuel and Air Systems' started by jedrattle, Oct 4, 2018.

  1. jedrattle

    jedrattle Well-Known Member

    Messages:
    252
    Likes Received:
    47
    Joined:
    Jul 31, 2005
    Location:
    Riverside ca
    Local Time:
    2:47 PM
    I had a friend rebuild my Street Averager 670cfm. We put it on the 360 and filled the float bowls through the vents. It fired right up with no issues. We shut it down and fired it up several times. Worked great!
    It sat overnight and would not start. I poured gas in and got it fired up that way. Once it ran for a min or two, it would shut down and start right back up with no problems. Fuel pump, timing, and float levels are good. I am stumped. What would cause this problem?
     
  2. Murray

    Murray FABO Gold Member FABO Gold Member

    Messages:
    724
    Likes Received:
    323
    Joined:
    Apr 19, 2010
    Location:
    San Jose, California
    Local Time:
    12:47 PM
    Sounds like carb is draining when shut off for a period of time. It could be flooding into the engine, or more likely , needle and seat are not holding and draining back to fuel pump.
     
  3. Dicer

    Dicer Well-Known Member

    Messages:
    364
    Likes Received:
    336
    Joined:
    Jan 12, 2016
    Location:
    Land of Lincoln
    Local Time:
    2:47 PM
    • Agree Agree x 1
    • jedrattle

      jedrattle Well-Known Member

      Messages:
      252
      Likes Received:
      47
      Joined:
      Jul 31, 2005
      Location:
      Riverside ca
      Local Time:
      2:47 PM
      Thanks for the response. We tore it apart to discover the pump spring was bound up and not letting it squirt fuel.