Rpms rapidly increase at startup

Discussion in 'Fuel and Air Systems' started by Kllrbee, Sep 6, 2018.

  1. Kllrbee

    Kllrbee Well-Known Member

    Messages:
    62
    Likes Received:
    47
    Joined:
    Jul 3, 2018
    Location:
    Richmond IL
    Local Time:
    10:17 PM
    6 bbl holley.
    Startup immediately at 1500 rpms then keeps climbing quickly. Finally cut it at 4k.
    Tried to WOT to reset fast cam lever...nothing. Kept increasing.
    Something binding?
    All I did beforehand was remove/reinstall secondary springs to see which ones they were and manually forced linkage forward to check how dirty underside of outboard plates are.
    What caused this rapid and continuous increase in rpms?

    Any more info u need, let me know.
     
  2. Tooljunkie

    Tooljunkie King of cobble/master of the broken bolt FABO Gold Member

    Messages:
    6,150
    Likes Received:
    4609
    Joined:
    Jul 22, 2017
    Location:
    Manitoba
    Local Time:
    10:17 PM
    Which one is stuck wide open?or did one become disconnected from the linkage and vacuum pulling it open?
     
    • Agree Agree x 1
    • TrailBeast

      TrailBeast Slightly Twisted Member

      Messages:
      18,843
      Likes Received:
      5038
      Joined:
      Mar 11, 2011
      Location:
      Arizona
      View My Photos
      Local Time:
      9:17 PM
      Throttle assembly and return spring/s on?
      Off the top it sounds like throttle plates opening without user input or a HUGE vacuum leak.

      Aint a lot of info there to go on.
       
      • Agree Agree x 1
      • TrailBeast

        TrailBeast Slightly Twisted Member

        Messages:
        18,843
        Likes Received:
        5038
        Joined:
        Mar 11, 2011
        Location:
        Arizona
        View My Photos
        Local Time:
        9:17 PM
        The "Great minds" saying? :D
         
      • AJ/FormS

        AJ/FormS 367 FormS clone 3.09-1.92-1.40-1.09-.78od 3.55s

        Messages:
        14,491
        Likes Received:
        3786
        Joined:
        Jan 19, 2014
        Location:
        South-Central Manitoba,Canada, 900ftelevation
        View My Photos
        Local Time:
        10:17 PM
        Secondaries are not closed
         
      • Kllrbee

        Kllrbee Well-Known Member

        Messages:
        62
        Likes Received:
        47
        Joined:
        Jul 3, 2018
        Location:
        Richmond IL
        Local Time:
        10:17 PM
        Yeah, it does seem like throttle opening, but the secondaries arent stuck open. I disconnected the linkage and closed them manually....still happens.
        Would have to be a pretty huge leak....what the heck is up here? Very strange.
         
      • AJ/FormS

        AJ/FormS 367 FormS clone 3.09-1.92-1.40-1.09-.78od 3.55s

        Messages:
        14,491
        Likes Received:
        3786
        Joined:
        Jan 19, 2014
        Location:
        South-Central Manitoba,Canada, 900ftelevation
        View My Photos
        Local Time:
        10:17 PM
        It has to be a throttle valve, cuz in order to hit 4000, there has to be fuel in that air. If it was dry air it would either peak or slow or stall/run very rough.

        Post #1 says 6bbl Holley; is that right?
         
      • Kllrbee

        Kllrbee Well-Known Member

        Messages:
        62
        Likes Received:
        47
        Joined:
        Jul 3, 2018
        Location:
        Richmond IL
        Local Time:
        10:17 PM
        Thats correct
         
      • AJ/FormS

        AJ/FormS 367 FormS clone 3.09-1.92-1.40-1.09-.78od 3.55s

        Messages:
        14,491
        Likes Received:
        3786
        Joined:
        Jan 19, 2014
        Location:
        South-Central Manitoba,Canada, 900ftelevation
        View My Photos
        Local Time:
        10:17 PM
        Well then stuff some rags in the outboards, and try again.

        waitaminute, where does the PCV plumb in?
         
      • Kllrbee

        Kllrbee Well-Known Member

        Messages:
        62
        Likes Received:
        47
        Joined:
        Jul 3, 2018
        Location:
        Richmond IL
        Local Time:
        10:17 PM
        Big nipple center carb base plate
         
      • Kllrbee

        Kllrbee Well-Known Member

        Messages:
        62
        Likes Received:
        47
        Joined:
        Jul 3, 2018
        Location:
        Richmond IL
        Local Time:
        10:17 PM
        I still had the vacuum hooked up to the secondaries...unplugged those and all good.
        So the other day I checked to see what springs were in there. (Car is new to me). Plain springs.
        I must have put them back in wrong cuz this wasnt happening before.
        Theres only one way for them to go in, cant see how I could have messed that up...lol.
        At 900 pm, when my car is screaming at 4k rpm in my garage and my neighbors start calling, I admit I felt some anxiety.
         
      • Steven190

        Steven190 FABO Gold Member FABO Gold Member

        Messages:
        692
        Likes Received:
        255
        Joined:
        Jan 13, 2012
        Location:
        Omaha
        Local Time:
        10:17 PM
        One time I had the weights in the distributor stick open, wide, and the car started and then gained rpm. new springs cured it up, just my thoughts, Good Luck
         
        • Like Like x 1
        • memike

          memike Super Moderator Staff Member FABO Gold Member

          Messages:
          49,926
          Likes Received:
          7464
          Joined:
          Jan 8, 2006
          Location:
          on the hill
          View My Photos
          Local Time:
          10:17 PM
          Could the Carb be leaning out do this men ?
           
        • Hellrats

          Hellrats Still wrenching after all these years FABO Gold Member

          Messages:
          749
          Likes Received:
          465
          Joined:
          Jan 24, 2012
          Location:
          Hartville, Ohio
          Local Time:
          11:17 PM
          I bet you have the secondaries vacuum line on the wrong nipple on the center carb. One goes to the vacuum advance on the distributor and the other one goes to the front and rear carbs.
           
        • Kllrbee

          Kllrbee Well-Known Member

          Messages:
          62
          Likes Received:
          47
          Joined:
          Jul 3, 2018
          Location:
          Richmond IL
          Local Time:
          10:17 PM
          They were wrong. Had dist right, but had pulloff on other one up top and secondaries on the base plate...not good. No wonder they opened at idle. That one should be where the pulloff goes right?
          Still weird that they werent opening at idle before I checked the springs. Could they have been binding and when I checked them, it freed them?
           
        • Kllrbee

          Kllrbee Well-Known Member

          Messages:
          62
          Likes Received:
          47
          Joined:
          Jul 3, 2018
          Location:
          Richmond IL
          Local Time:
          10:17 PM
          They were wrong. Had dist right, but had pulloff on other one up top and secondaries on the base plate...not good. No wonder they opened at idle. That one should be where the pulloff goes right?
          Still weird that they werent opening at idle before I checked the springs. Could they have been binding and when I checked them, it freed them?