Still not getting power steering assist

Suspension, Steering and Chassis

  1. MrJLR

    MrJLR Built, not bought FABO Gold Member

    Messages:
    4,370
    Likes Received:
    3261
    Joined:
    May 14, 2015
    Location:
    Chino, California
    Local Time:
    8:02 AM
    Even tried a new pump...

    With new pump:
    No air bubbles. ..I guess it's bled now...
    With wheels off the ground and engine running, I turn the wheel back and forth and it is clearly easier than without the engine running...there must be "some" assist. ...
    Put it back on the ground and it's like manual steering. ....

    Pulling my hair out on this one...
    Any thoughts?

    Jeff
     
  2. diymirage

    diymirage HP@idle > hondaHP@redline

    Messages:
    14,949
    Likes Received:
    7329
    Joined:
    Oct 12, 2012
    Location:
    michigan
    Local Time:
    11:02 AM
    hoses on backwards?

    plug still in there?
     
    • Thanks! Thanks! x 1
    • diymirage

      diymirage HP@idle > hondaHP@redline

      Messages:
      14,949
      Likes Received:
      7329
      Joined:
      Oct 12, 2012
      Location:
      michigan
      Local Time:
      11:02 AM
      wasnt untill i went to look for the picture of that plug, i realized that was also you...didnt mean to kick you while you were down
       
      • Thanks! Thanks! x 1
      • MrJLR

        MrJLR Built, not bought FABO Gold Member

        Messages:
        4,370
        Likes Received:
        3261
        Joined:
        May 14, 2015
        Location:
        Chino, California
        Local Time:
        8:02 AM
        Kinda inpossible to put the hoses on wrong...
        No plugs...

        This really should be easy...it's just a stupid pump.....
        Everything was fine until I endeavored to fix my leak lol...!

        Jeff
         
        • Like Like x 1
        • MrJLR

          MrJLR Built, not bought FABO Gold Member

          Messages:
          4,370
          Likes Received:
          3261
          Joined:
          May 14, 2015
          Location:
          Chino, California
          Local Time:
          8:02 AM
          I saw a thread where someone forgot a plug...not me...lol

          Jeff
           
        • diymirage

          diymirage HP@idle > hondaHP@redline

          Messages:
          14,949
          Likes Received:
          7329
          Joined:
          Oct 12, 2012
          Location:
          michigan
          Local Time:
          11:02 AM
          gotcha

          ok, so its easier with the wheels of the ground and the engine running then with the engine off, correct?

          meaning it does assist "some" but not as much as you want
          are these pumps adjustable?
           
          • Thanks! Thanks! x 1
          • MrJLR

            MrJLR Built, not bought FABO Gold Member

            Messages:
            4,370
            Likes Received:
            3261
            Joined:
            May 14, 2015
            Location:
            Chino, California
            Local Time:
            8:02 AM
            No...once the wheels are on the ground, it's like no assist at all...
            I only can feel assist with the wheels off the ground...so it must not be very much at all...but it is noticeable. ...

            But back on the ground it's like zero...

            Jeff
             
          • diymirage

            diymirage HP@idle > hondaHP@redline

            Messages:
            14,949
            Likes Received:
            7329
            Joined:
            Oct 12, 2012
            Location:
            michigan
            Local Time:
            11:02 AM
            with the wheels of the ground, and the engine off, is it the same or harder then with the engine on?
            at some point, we need to perhaps quit looking at the pump and start looking at the steering box?

            have you verified there is pressure on the output hose of the pump ?
             
            • Thanks! Thanks! x 1
            • MrJLR

              MrJLR Built, not bought FABO Gold Member

              Messages:
              4,370
              Likes Received:
              3261
              Joined:
              May 14, 2015
              Location:
              Chino, California
              Local Time:
              8:02 AM
              I've been bleeding and re-bleeding, and testing and re-bleeding all day it seems...ugh.

              Jeff
               
            • MrJLR

              MrJLR Built, not bought FABO Gold Member

              Messages:
              4,370
              Likes Received:
              3261
              Joined:
              May 14, 2015
              Location:
              Chino, California
              Local Time:
              8:02 AM
              On the ground it feels the same engine on or off...
              Everything worked fine prior to this...I don't know what could have happened to the box...?

              Jeff
               
            • MrJLR

              MrJLR Built, not bought FABO Gold Member

              Messages:
              4,370
              Likes Received:
              3261
              Joined:
              May 14, 2015
              Location:
              Chino, California
              Local Time:
              8:02 AM
              Seems there MUST still be air in the system. ...

              Jeff
               
            • diymirage

              diymirage HP@idle > hondaHP@redline

              Messages:
              14,949
              Likes Received:
              7329
              Joined:
              Oct 12, 2012
              Location:
              michigan
              Local Time:
              11:02 AM
              why did you pull the pump?


              would it be possible you got one from a magnum on an LA and its running the wrong direction?
               
              • Thanks! Thanks! x 1
              • MrJLR

                MrJLR Built, not bought FABO Gold Member

                Messages:
                4,370
                Likes Received:
                3261
                Joined:
                May 14, 2015
                Location:
                Chino, California
                Local Time:
                8:02 AM
                I pulled it to replace a leaking seal...
                And the new pump I'm currently trying to make work it's for 74 to 76 abody mopar. ..it's an exact match to my old one...

                So freaking exact that it doesn't work either! Lol

                Jeff
                 
                • Like Like x 1
                • pishta

                  pishta I know I'm right....

                  Messages:
                  14,035
                  Likes Received:
                  3721
                  Joined:
                  Oct 13, 2004
                  Location:
                  Tustin, CA
                  Local Time:
                  8:02 AM
                  Is the procedure to bleed the pump just turning the wheel back and forth lock to lock a few times? Could you take box to a trans shop and have them bench test it for 1200 psi pressure? Read this article on how to reduce your pressure and you'll be able to increase it too.
                  Moparts on the Web - Main Index
                   
                  • Thanks! Thanks! x 1
                  • MrJLR

                    MrJLR Built, not bought FABO Gold Member

                    Messages:
                    4,370
                    Likes Received:
                    3261
                    Joined:
                    May 14, 2015
                    Location:
                    Chino, California
                    Local Time:
                    8:02 AM
                    Yes....that is the basic procedure. ...and I've done a LOT of it.....
                    Cool link!

                    Jeff
                     
                  • diymirage

                    diymirage HP@idle > hondaHP@redline

                    Messages:
                    14,949
                    Likes Received:
                    7329
                    Joined:
                    Oct 12, 2012
                    Location:
                    michigan
                    Local Time:
                    11:02 AM
                    Well, what about this thougt...what if there is an obstruction and that caused the seal to fail?
                    Pressing fluid out the only way it could go
                     
                    • Thanks! Thanks! x 1
                    • MrJLR

                      MrJLR Built, not bought FABO Gold Member

                      Messages:
                      4,370
                      Likes Received:
                      3261
                      Joined:
                      May 14, 2015
                      Location:
                      Chino, California
                      Local Time:
                      8:02 AM
                      Could be. ...I guess I'm going to have to go back to square one. ...
                      Pull it off...make sure the spring loaded valve moves freely, make sure there's no obstructions in the lines...etc.

                      Damn thing is kicking my ass...
                      If it was easy, everyone would do it!

                      I want to wrap this up because my awesome new electric fans and controller are sitting in my garage waiting for install.
                      This and the fans will wrap up this year's projects and I can get back to driving and enjoying her!

                      When I finally do get this figured out I'll let ya'll know what it turned out to be. ....

                      Of course, if anyone has any more ideas, I'm all ears!

                      Jeff
                       
                    • TrailBeast

                      TrailBeast Slightly Twisted Member

                      Messages:
                      19,499
                      Likes Received:
                      5927
                      Joined:
                      Mar 11, 2011
                      Location:
                      Arizona
                      Local Time:
                      8:02 AM
                      A functional pump will bleed itself of air with only a couple of turns back and forth.
                      Under your circumstances I'd be checking to make sure my pressure side hose wasn't collapsed inside from moving it around during the swaps.
                       
                      • Thanks! Thanks! x 1
                      • MrJLR

                        MrJLR Built, not bought FABO Gold Member

                        Messages:
                        4,370
                        Likes Received:
                        3261
                        Joined:
                        May 14, 2015
                        Location:
                        Chino, California
                        Local Time:
                        8:02 AM
                        I kinda thought it shouldn't be this hard....lol
                        That's something I'll check for sure...
                        My high pressure hose, the fitting wouldn't screw into the port on the new pump, so I swapped out the port from my old pump to the new one... They pretty much looked identical, but I wonder if that's the issue...?

                        Jeff
                         
                      • MrJLR

                        MrJLR Built, not bought FABO Gold Member

                        Messages:
                        4,370
                        Likes Received:
                        3261
                        Joined:
                        May 14, 2015
                        Location:
                        Chino, California
                        Local Time:
                        8:02 AM
                        This is the port I swapped. ..

                        20180803_175235.jpg

                        20180803_175244.jpg

                        I would gladly just buy a new power steering hose and use the new port that came with it but I don't know what type of fitting that is...

                        Jeff
                         
                      • MrJLR

                        MrJLR Built, not bought FABO Gold Member

                        Messages:
                        4,370
                        Likes Received:
                        3261
                        Joined:
                        May 14, 2015
                        Location:
                        Chino, California
                        Local Time:
                        8:02 AM
                        The pump is a Saginaw PS6021

                        OER PS6021

                        The trick is getting the correct hose for my car/application. ..
                        There are a zillion different types. ..

                        Jeff
                         
                        Last edited: Aug 3, 2018
                      • diymirage

                        diymirage HP@idle > hondaHP@redline

                        Messages:
                        14,949
                        Likes Received:
                        7329
                        Joined:
                        Oct 12, 2012
                        Location:
                        michigan
                        Local Time:
                        11:02 AM
                        Take it in to a hydraulics shop and have them make hoses for it
                        They prolly have the fitting too
                         
                        • Thanks! Thanks! x 1
                        • MrJLR

                          MrJLR Built, not bought FABO Gold Member

                          Messages:
                          4,370
                          Likes Received:
                          3261
                          Joined:
                          May 14, 2015
                          Location:
                          Chino, California
                          Local Time:
                          8:02 AM
                          Good idea....there's actually a shop right near my work called "The Hose Man"....
                          Monday at lunch...!
                          I bet that's the problem. ..

                          Jeff
                           
                        • Tooljunkie

                          Tooljunkie King of cobble/master of the broken bolt FABO Gold Member

                          Messages:
                          8,605
                          Likes Received:
                          7117
                          Joined:
                          Jul 22, 2017
                          Location:
                          Manitoba
                          Local Time:
                          10:02 AM
                          Not on a mopar, but i spun up a pump with my drill,the oil sure flies when its working right.

                          I also remember when i re sealed my power steering box in the power wagon, it was a battle,like it airlocked.
                          Running it with the cap off and not going lock to lock was the ticket. It would aerate the fluid if i went to lock.
                           
                          • Thanks! Thanks! x 2
                          • Agree Agree x 1
                          • diymirage

                            diymirage HP@idle > hondaHP@redline

                            Messages:
                            14,949
                            Likes Received:
                            7329
                            Joined:
                            Oct 12, 2012
                            Location:
                            michigan
                            Local Time:
                            11:02 AM
                            Well...did you get hosed ?
                             
                            • Like Like x 2
                            1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
                              By continuing to use this site, you are consenting to our use of cookies.