turn signals not working

Electrical and Ignition

  1. Tarek Baratta

    Tarek Baratta Well-Known Member

    Messages:
    45
    Likes Received:
    27
    Joined:
    Dec 1, 2019
    Location:
    Delta BC
    Local Time:
    2:18 AM
    like the titles says, my turn signals are not working, hazards work, the flasher works as swapped it with the hazards flasher, brakes, headlights, just turn signals, tested with power probe, getting power to flasher when switching switch any ideas?

    Car is a 75 Plymouth valiant
     
  2. Mouse action

    Mouse action Well-Known Member

    Messages:
    162
    Likes Received:
    295
    Joined:
    Oct 16, 2019
    Location:
    Brooklyn
    Local Time:
    5:18 AM
    Most likely the signal switch in the column
     
  3. 67Dart273

    67Dart273 FABO Gold Member FABO Gold Member

    Messages:
    42,354
    Likes Received:
    9993
    Joined:
    Oct 14, 2010
    Location:
    Idaho
    Local Time:
    2:18 AM
    I would agree with above^^ Try working the SHXX out of the hazard switch about 10 times and see if anything changes. But it likely is the TS switch.
     
  4. Tarek Baratta

    Tarek Baratta Well-Known Member

    Messages:
    45
    Likes Received:
    27
    Joined:
    Dec 1, 2019
    Location:
    Delta BC
    Local Time:
    2:18 AM
    so was messing around with wiper switch, powered one connector and heard clicking, was turn signal, the switch is working, but only when powering one terminal on my wiper switch connector, I'm guessing one shorted wire
     
  1. This site uses cookies to help personalize content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.