The slant idle gets stuck??

Discussion in 'Fuel and Air Systems' started by gdizzle, Nov 12, 2018.

  1. gdizzle

    gdizzle Well-Known Member

    Messages:
    889
    Likes Received:
    106
    Joined:
    May 25, 2015
    Location:
    los angeles
    Local Time:
    12:43 AM
    66 slant dart, running the supersix setup. Been running real good. Got my idle dialed in. Now recently, outta the blue, I start the car and the idle is way high, 1200rpm. And no matter what I do, tap the pedal etc... it wont drop down, and in fact is very slow to reduce RPM to 1200 even.

    I open hood, and mess with things, nothing helps. I mess with throttle plates, close them and engine dies. Then restart and it is fine , meaning cold idle is at 850 at park.

    This has now happened twice. Any idea what is going on? something inside the Carter BBD?
     
  2. bbrroowwnn

    bbrroowwnn never re member FABO Gold Member

    Messages:
    10,470
    Likes Received:
    464
    Joined:
    Nov 27, 2010
    Location:
    Drums, PA
    View My Photos
    Local Time:
    1:43 AM
    choke?
     
  3. gdizzle

    gdizzle Well-Known Member

    Messages:
    889
    Likes Received:
    106
    Joined:
    May 25, 2015
    Location:
    los angeles
    Local Time:
    12:43 AM
    No choke
     
  4. jas0162

    jas0162 Well-Known Member

    Messages:
    248
    Likes Received:
    98
    Joined:
    Apr 23, 2014
    Location:
    kansas
    Local Time:
    12:43 AM
    Sounds like the fast idle cam is hanging up. Mine does that sometimes.
     
  5. gdizzle

    gdizzle Well-Known Member

    Messages:
    889
    Likes Received:
    106
    Joined:
    May 25, 2015
    Location:
    los angeles
    Local Time:
    12:43 AM
    how do you lube that thing? WD40?
     
  6. 383Scampman

    383Scampman Well-Known Member

    Messages:
    997
    Likes Received:
    327
    Joined:
    Nov 24, 2013
    Location:
    New Hampshire
    Local Time:
    1:43 AM
    You may have some dirt in the idle circuit or in the transition circuit to the main jets .
     
  7. jas0162

    jas0162 Well-Known Member

    Messages:
    248
    Likes Received:
    98
    Joined:
    Apr 23, 2014
    Location:
    kansas
    Local Time:
    12:43 AM
    After rereading your original post it sounds more like you need to take the carb apart and blow it out. The fast idle cam is easy to see and diagnose, mine always hangs up after applying the choke on a cold start. WD40 fixes it for a while but it always does it again, I think I need to take it off and clean and/or polish the sticky parts that are supposed to slip and slide
     
    • Agree Agree x 1