‘68 Dart, One tail light not working.

-

FlamesAreWicked

Active Member
Joined
May 10, 2024
Messages
38
Reaction score
45
Location
Louisiana
replaced bulb and still not getting a brake light or turn signal light on the driver rear..while removing a nest of speaker wires and radio wiring from an aftermath radio that was added in the past I did come across this little dude that was very warm to the touch when nothing was on..

IMG_9481.jpeg


Obviously local parts stores don’t even have a listing for such. Just the normal 2 terminal flasher, which it also has.. I don’t think this is my tail light issue but I don’t think it’s supposed to be hot like that at idle.. checked the harness plugs and sprayed contact cleaner on them.. still nothing. Another thing I need to replace is the turn signal switch. The little plastic cam I guess you call it broke and it doesn’t stay engaged when you turn on the right side blinker …

Thoughts, opinions, suggestions are welcomed ..
 
Last edited:
replaced bulb and still not getting a brake light or turn signal light on the driver rear..while removing a nest of speaker wires and radio wiring from an aftermath radio that was added in the past I did come across this little dude that was very warm to the touch when nothing was on..

View attachment 1716255196

Obviously local parts stores don’t even have a listing for such. Just the normal 2 terminal flasher, which it also has.. I don’t think this is my tail light issue but I don’t think it’s supposed to be hot like that at idle.. checked the harness plugs and sprayed contact cleaner on them.. still nothing. Another thing I need to replace is the turn signal switch. The little plastic cam I guess you call it broke and it doesn’t stay engaged when you turn on the right side blinker …

Thoughts, opinions, suggestions are welcomed ..
looks like the time delay power relay.
 
Sometimes the bulg socket does not make a good ground, might want to check that
 
Sometimes the bulg socket does not make a good ground, might want to check that
Also, after finding a few threads on here.. I’m gonna make sure my turn signal switch is sending power out.. if that ends up being the case, the signal cam is broken anyhow so, it’ll be a prime time to fix that as well… I’ll update later today with what I find.
 
Update.. well I think I have something … some shoddy wiring.. leads me to believe it needs a new headlight switch. I wasn’t getting power going into the turn signal switch for the driver side rear.. if I’m following the schematic right, headlight switch feeds it… pulled the plug on the headlight switch and I find this. The wires on the exit look good, plug itself looks good… best guess is the headlight switch needs to be replaced since one end of that jumper wire goes to the wiring to the left rear tail. Sounds logical anyhow.. I can’t imagine this is factory :lol:

IMG_9489.jpeg
 
I replaced the turn signal switch today and forgot to put what looks like a capacitor back inside the column near the switch. Following the schematic, it goes to the radio and fuse box on the opposite end. The radio in the car currently isn’t working anyhow.. will I need to put it back in ?

IMG_9521.jpeg
 
Last edited:
In other news, my brake light problem has been resolved :thumbsup:

It was the turn signal switch. If the only purpose of that cap is for the factory radio.. I’ll leave it out and put it all back together..
 
The first device you pictured is a delay relay

The second does not look like a cap. You sure it's not a lamp? What does the other side look like? Shift quadrant lamp?

PLEASE ALWAYS POST the year make model
 
I had a driver's side tail light out, searched everywhere and found the problem in the turn signal switch. It had burned out a soldered connection on the internal board that holds the plastic/nylon turn signal cancelling mechanism.
 
The first device you pictured is a delay relay

The second does not look like a cap. You sure it's not a lamp? What does the other side look like? Shift quadrant lamp?

PLEASE ALWAYS POST the year make model
The title has the year and model. After looking at it again.. it could be a lamp. My shift indicator needle is missing also. The wire going to it is in pretty rough shape and has a splice in it in addition to some spots where it’s been taped up because the wire is showing
 
Do you have the shop manual and parts books? Pretty sure www.mymopar.com has both for '68. I have paper original and CD for 68 so haven't looked but pretty sure mymopar has them.

Yellow insulation was used for dome light return, map light, etc. Orange was typically used for instrument lights including optional tach, shift indicator, etc.
Since there is a delay unit, there could be some other optional or less typical harness connections.
 
Do you have the shop manual and parts books? Pretty sure www.mymopar.com has both for '68. I have paper original and CD for 68 so haven't looked but pretty sure mymopar has them.

Yellow insulation was used for dome light return, map light, etc. Orange was typically used for instrument lights including optional tach, shift indicator, etc.
Since there is a delay unit, there could be some other optional or less typical harness connections.
I do not, I’ll give them a look.. I do have a wiring schematic from classiccarwiring.comthe laminated schematic. It’s the indicator bulb. I don’t plan to keep it an automatic in the long term or even in the next year or so. Is there any harm to be done buy not having it ? I found a couple on eBay for $30-$40 that are used but decent shape..
 
Update.. well I think I have something … some shoddy wiring.. leads me to believe it needs a new headlight switch. I wasn’t getting power going into the turn signal switch for the driver side rear.. if I’m following the schematic right, headlight switch feeds it… pulled the plug on the headlight switch and I find this. The wires on the exit look good, plug itself looks good… best guess is the headlight switch needs to be replaced since one end of that jumper wire goes to the wiring to the left rear tail. Sounds logical anyhow.. I can’t imagine this is factory :lol:

View attachment 1716255411

I have not looked into the plug, but in 68 the park lights still went off when you turned the headlights on. If you want both you can run a jumper wire on the switch to make them stay on.
 
The ignition time delay relay is for the ignition switch lamp,it will turn on the switch light and after you close the door the light will stay on for 10 sec and then turn off.
Is it possible that thing with the yellow wire is that lamp?
On my 1975 Plymouth Valiant Custom its located near the Hazard switch.
 
-
Back
Top